Trucs et logiciels

Les astuces ne doivent pas finir à la corbeille !

Archives de Catégorie: Debian

Xorg 1.10 n’aime pas nvidia-173

Hier, j’ai tranquillou fait ma mise à jour d’Arch avant d’aller me coucher, et en redémarrant ce matin j’ai eu un joli message d’erreur lors du démarrage en console :

This server has a video driver ABI version of 10.0 that is not supported by this NVIDIA driver. Please check http://nvidia.com for drivers updates or downgrade to an X server with a supported driver ABI.

(EE) Screen(s) found, but none have a usable configuration.

Fatal sever error:
No screens found

J’utilise le driver nvidia-173.

Pour avoir de nouveau un bel affichage graphique, j’ai donc downgradé le serveur X comme décrit sur le forum brésilien. Comme ma connexion internet ne vient qu’avec nm-applet en session Xfce (il faut que je rentre la clé à chaque fois), je n’ai pas pu chercher comment downgrader avec elinks (surtout les versions des paquets à réinstaller en fait), j’ai donc chrooté à partir de ma LMDE.
Lire la suite

Publicités

LMDE : « Impossible d’appliquer les changements. Réparez d’abord les paquets cassés. »

Aujourd’hui, j’ai voulu mettre à jour ma LMDE (Linux Mint Debian Edition). J’ai donc lancé MintUpdate, il m’a trouvé plein de mises à jour, et lorsque j’ai voulu les appliquer, il m’a balancé cette erreur :

Impossible d’appliquer les changements.
Réparez d’abord les paquets cassés.

Ok, cherchons donc ces paquets cassés. J’essaie avec Synaptic, dans les filtres personnalisés, puis dans « cassés », en espérant qu’il m’affiche les paquets posant problèmes. Que nenni, rien, nada. Aucun paquet cassé selon lui. Rechargement de la liste des paquets, essai à nouveau, retour dans MintUpdate, et l’erreur est toujours là.

C’est sur le forum de Cyrille BORNE, plus précisément le sujet traitant (comme par hasard) de la réparation des paquets sous LMDE, que j’ai trouvé comment afficher les paquets cassés : en faisant une simulation de mise à jour avec aptitude.
Lire la suite