Trucs et logiciels

Les astuces ne doivent pas finir à la corbeille !

Xorg 1.10 n’aime pas nvidia-173

Hier, j’ai tranquillou fait ma mise à jour d’Arch avant d’aller me coucher, et en redémarrant ce matin j’ai eu un joli message d’erreur lors du démarrage en console :

This server has a video driver ABI version of 10.0 that is not supported by this NVIDIA driver. Please check http://nvidia.com for drivers updates or downgrade to an X server with a supported driver ABI.

(EE) Screen(s) found, but none have a usable configuration.

Fatal sever error:
No screens found

J’utilise le driver nvidia-173.

Pour avoir de nouveau un bel affichage graphique, j’ai donc downgradé le serveur X comme décrit sur le forum brésilien. Comme ma connexion internet ne vient qu’avec nm-applet en session Xfce (il faut que je rentre la clé à chaque fois), je n’ai pas pu chercher comment downgrader avec elinks (surtout les versions des paquets à réinstaller en fait), j’ai donc chrooté à partir de ma LMDE.

Je n’avais pas les mêmes paquets que dit dans le sujet, j’ai donc installé

  • xorg-server-1.9.4.901-1-i686.pkg.tar.xz
  • xorg-server-common-1.9.4.901-1-i686.pkg.tar.xz
  • xf86-input-evdev-2.6.0-2-i686.pkg.tar.xz

qui ont supprimé

  • xf86-video-nouveau-0.0.16_git20110316-2
  • xf86-video-vesa-2.3.0-5

puis installé des versions antérieures de ces deux derniers paquets :

  • xf86-video-vesa-2.3.0-4-i686.pkg.tar.xz
  • xf86-video-nouveau-0.0.16_git20101217-1-i686.pkg.tar.xz
_____________________________________
( Mon ombre est une compagne, pas une )
( amie.                               )
(                                     )
( -+- Jacques-Henri Lartigue -+-      )
 -------------------------------------
  o
   o
       ___  
     {~._.~}
      ( Y )
     ()~*~()   
     (_)-(_)   
stephmint@satellitem30-laptop ~ $ sudo chroot /media/racineArchlinux/ /bin/bash
[sudo] password for stephmint: 
bash: /dev/null: Permission non accordée
[root@satellitem30-laptop /]# cd /var/cache/pacman/pkg
[root@satellitem30-laptop pkg]# pacman -U xorg-server-1.9.4.901-1-i686.pkg.tar.xz xorg-server-common-1.9.4.901-1-i686.pkg.tar.xz xf86-input-evdev-2.6.0-2-i686.pkg.tar.xz
Avertissement: retourne à la version antérieure du paquet xorg-server (1.10.0.902-1 => 1.9.4.901-1)
Avertissement: retourne à la version antérieure du paquet xorg-server-common (1.10.0.902-1 => 1.9.4.901-1)
Avertissement: retourne à la version antérieure du paquet xf86-input-evdev (2.6.0-3 => 2.6.0-2)
Résolution des dépendances...
Recherche des conflits possibles entre paquets...
:: xorg-server et xf86-video-nouveau sont en conflit (xorg-server<1.10.0). Supprimer xf86-video-nouveau ? [o/N] o
:: xorg-server et xf86-video-vesa sont en conflit (xorg-server<1.10.0). Supprimer xf86-video-vesa ? [o/N] o

Suppression (2): xf86-video-nouveau-0.0.16_git20110316-2
                 xf86-video-vesa-2.3.0-5

Taille totale des paquets (suppression):   0,25 Mo

Cibles (3): xorg-server-common-1.9.4.901-1  xf86-input-evdev-2.6.0-2
            xorg-server-1.9.4.901-1

Taille totale des paquets (téléchargement):   0,00 Mo
Taille totale des paquets (installation):   3,64 Mo

Procéder à l'installation ? [O/n] o
(3/3) vérification de l'intégrité des paquets      [######################] 100%
(3/3) Analyse des conflits entre fichiers          [######################] 100%
(1/2) Désinstallation de xf86-video-nouveau        [######################] 100%
(2/2) Désinstallation de xf86-video-vesa           [######################] 100%
(1/3) Mise à jour de xorg-server-common            [######################] 100%
(2/3) Mise à jour de xf86-input-evdev              [######################] 100%
(3/3) Mise à jour de xorg-server                   [######################] 100%
[root@satellitem30-laptop pkg]# pacman -U xf86-video-vesa-2.3.0-4-i686.pkg.tar.xz 
Résolution des dépendances...
Recherche des conflits possibles entre paquets...

Cibles (1): xf86-video-vesa-2.3.0-4

Taille totale des paquets (téléchargement):   0,00 Mo
Taille totale des paquets (installation):   0,07 Mo

Procéder à l'installation ? [O/n] o
(1/1) vérification de l'intégrité des paquets      [######################] 100%
(1/1) Analyse des conflits entre fichiers          [######################] 100%
(1/1) Installation de xf86-video-vesa              [######################] 100%
[root@satellitem30-laptop pkg]# pacman -U xf86-video-nouveau-0.0.16_git20101217-1-i686.pkg.tar.xz 
Résolution des dépendances...
Recherche des conflits possibles entre paquets...

Cibles (1): xf86-video-nouveau-0.0.16_git20101217-1

Taille totale des paquets (téléchargement):   0,00 Mo
Taille totale des paquets (installation):   0,18 Mo

Procéder à l'installation ? [O/n] o
(1/1) vérification de l'intégrité des paquets      [######################] 100%
(1/1) Analyse des conflits entre fichiers          [######################] 100%
(1/1) Installation de xf86-video-nouveau           [######################] 100%
  ==> make sure you use KernelModeSetting (KMS)
  ==> see http://wiki.archlinux.org/index.php/Nouveau#KMS for more
Dépendances optionnelles pour xf86-video-nouveau
    nouveau-dri:	experimental gallium3d features
[root@satellitem30-laptop pkg]# exit
stephmint@satellitem30-laptop ~ $ 
Publicités

11 réponses à “Xorg 1.10 n’aime pas nvidia-173

  1. helly 13 avril 2011 à 11:49

    HAHA !
    Bha tu peux en profiter pour essayer wayland ! 😛

    • kamui57 13 avril 2011 à 12:59

      Il y a déja eu une mise à jour comme ça où il fallait utiliser nouveau ou downgrader (pour Xorg 1.8 je crois), et après quelque temps le driver nvidia avait de nouveau marché. Jpense que ça va être pareil 😉

      Wayland est compatible avec le driver nvidia ? ici http://www.nvnews.net/vbulletin/showthread.php?p=2343452 nvidia dit qu’ils ne vont pas le supporter. Et nouveau n’a pas encore l’accélération 3D, or quand Gnome3 sera dans extra j’aimerais bien l’essayer donc jpeux pas changer pour nouveau. Ou alors on peut tester Gnome3 sans utiliser d’autres paquets de testing ?

      Je viens de voir qu’en fait la 3d dans nouveau est expérimentale http://wiki.archlinux.fr/NVIDIA#Installation_2, je vais tester ça.

      edit : ben chez moi ça marche pas… rien de nouveau quoi.

  2. grim 13 avril 2011 à 17:44

    Arf, dommage pour Nouveau 😦
    Pour ma carte ça fonctionne, et il me semble que pour celle de Кຼزດ aussi.
    Cela dit, c’est un driver qui évolue rapidement donc tu peux réessayer de temps en temps (on ne sait jamais ;)).

    • kamui57 13 avril 2011 à 18:31

      Je viens de m’apercevoir que nouveau-dri n’est pas installé (il demandait de supprimer nvidia-173xx-utils, et ne supprimait pas nvidia-173xx tout seul, du coup j’ai supprimé nvidia-173xx mais oublié de relancer l’installation ensuite… boulette ;-)). Je reteste 🙂

      edit : YYEEAAAHHH !
      19:33:27 stepharch@mittelerde:~ 1$ glxinfo | grep « direct rendering »
      direct rendering: Yes
      19:33:52 stepharch@mittelerde:~ 2$
      M’en fais jouer avec compiz et si ça marche, à moi Xorg 1.10 !

  3. grim 13 avril 2011 à 18:34

    \o/ Un nouvel espoir 🙂
    Au pire, jette un œil sur le wiki anglais (il me semble plus complet que le fr).
    => https://wiki.archlinux.org/index.php/Nouveau
    (il n’y a que chez moi que le CSS est en berne sur le wiki ?)

    • kamui57 13 avril 2011 à 18:38

      punaise ça roxxx j’ai l’impression que le cube est plus fluide qu’avec le driver proprio Oo, mais ya des bugs d’affichage. Le driver est encore expérimental, donc c’est pas un problème, ils vont les résoudre 🙂
      Chez moi le wiki est ok, même en vidant le cache, avec ff4.

      • grim 13 avril 2011 à 18:44

        \o/, yeah.
        Moi aussi j’avais des bugs au début, mais ils disparaissent au fur et à mesure des release donc j’espère que ça va faire pareil pour toi 😉

        Pour le wiki je m’en doutais un peu… Je sens que je vais pas tarder à changer de navigateur (mais j’en trouve aucun à mon goût pour le moment…), Surf commence à me gaver avec ses petits défauts qui ont tendance à se cumuler :/

  4. kamui57 13 avril 2011 à 18:52

    Certains (genre helly 😉 ) sont fans de uzbl, un navigateur aussi « minimaliste » comme m’a l’air d’être surf :
    http://linuxfr.org/users/enixos/journaux/uzbl-un-navigateur-internet-rien-quun-navigateur-internet
    http://doc.ubuntu-fr.org/uzbl
    edit : je viens de mettre à jour le système, et donc nouveau, il y a déja moins de bugs d’affichage 🙂 même si avant y en avait pas beaucoup.

  5. grim 13 avril 2011 à 18:59

    Ouais je connais, je troll souvent helly à ce sujet 😀
    Nan mais uzbl c’est pire : il est plus gros (en ligne de code) et plus lourd (alors que niveau fonctionnalités c’est vraiment kif-kif) et le fichier de conf’ est moche (oui, sur ce point c’est subjectif).
    Au pire j’ai w3m ^^ »

    • grim 13 avril 2011 à 19:00

      Ha WordPress remplace encore les doubles quotes par  » >_<

      • kamui57 13 avril 2011 à 19:07

        Ouais, et quand j’ai voulu poster la sortie du terminal tout à l’heure dans la sortie de pacman y avait un qui me faisait sauter un bloc de code. Il a fallu que je le remplace par & l t ; pour que ça marche. Je me demande si c’est pareil en téléchargeant wordpress et en l’installant sur un hébergeur.

        edit : bah voilà j’ai trouvé comment améliorer le code !
        http://en.support.wordpress.com/code/posting-source-code/

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

%d blogueurs aiment cette page :