Trucs et logiciels

Les astuces ne doivent pas finir à la corbeille !

Xorg 1.10 n’aime pas nvidia-173

Hier, j’ai tranquillou fait ma mise à jour d’Arch avant d’aller me coucher, et en redémarrant ce matin j’ai eu un joli message d’erreur lors du démarrage en console :

This server has a video driver ABI version of 10.0 that is not supported by this NVIDIA driver. Please check http://nvidia.com for drivers updates or downgrade to an X server with a supported driver ABI.

(EE) Screen(s) found, but none have a usable configuration.

Fatal sever error:
No screens found

J’utilise le driver nvidia-173.

Pour avoir de nouveau un bel affichage graphique, j’ai donc downgradé le serveur X comme décrit sur le forum brésilien. Comme ma connexion internet ne vient qu’avec nm-applet en session Xfce (il faut que je rentre la clé à chaque fois), je n’ai pas pu chercher comment downgrader avec elinks (surtout les versions des paquets à réinstaller en fait), j’ai donc chrooté à partir de ma LMDE.
Lire la suite

Rencontres multimédia à Thionville (57) : compte-rendu

Salut à tous !

Par avance, désolée pour les nombreuses grandes photos, et pour la non-intégration des vidéos, mais wordpress ne veut pas de la balise vidéo.

Le 8 mars, je vois un article intéressant dans le journal (photo de l’article à venirjournal jeté malencontreusement😦 mais si vous l’avez, faites-moi signe !) sur les rencontres multimédia à Thionville, le lendemain, salle Albert Schweitzer. Sujets : surtout les jeux vidéos, aussi les logiciels libres.

Voulant en savoir plus, je fouille sur internet et trouve la page dédiée sur le wikithionville (j’le connaissais pas c’lui-là), sous license CC-BY-NC-SA, le programme est mieux détaillé :

Déroulement des Rencontres Régionales Multimédias : le mercredi 9 mars de 13h30 à 19 h00, à Thionville, Salle Schweitzer

  • 13h30 / 14h00 : Accueil des participants
  • 14h00 : présentation des ateliers de pratique et animation par des jeunes Jeux vidéo / RPG Maker en pratique / Logiciels libres / la machines (monter / démonter) / Créer avec une palette graphique / Court métrage / Film animation / réalisation vidéo / création de contenus pour blog / utilisation du wikithionville (web collaboratif)
  • à partir de 15h30 : des séances de diffusion vidéo
  • Un temps de réflexion avec un intervenant pour donner quelques éléments d’analyses de pratiques, quelques repères, souligner les risques et les avantages des pratiques d’internet et du multimédia chez les ados
  • Un temps de synthèse général en fin d’après midi : un retour sur l’expérimentation dans les ateliers

Un post sur le forum Ubuntu-fr au cas où y aurait des GNU/Linuxiens dans le coin, un tour par Google maps pour savoir où est la salle Albert Schweitzer sachant qu’elle est Passage du Temple, et me voilà prête à y aller.
Lire la suite

LMDE : « Impossible d’appliquer les changements. Réparez d’abord les paquets cassés. »

Aujourd’hui, j’ai voulu mettre à jour ma LMDE (Linux Mint Debian Edition). J’ai donc lancé MintUpdate, il m’a trouvé plein de mises à jour, et lorsque j’ai voulu les appliquer, il m’a balancé cette erreur :

Impossible d’appliquer les changements.
Réparez d’abord les paquets cassés.

Ok, cherchons donc ces paquets cassés. J’essaie avec Synaptic, dans les filtres personnalisés, puis dans « cassés », en espérant qu’il m’affiche les paquets posant problèmes. Que nenni, rien, nada. Aucun paquet cassé selon lui. Rechargement de la liste des paquets, essai à nouveau, retour dans MintUpdate, et l’erreur est toujours là.

C’est sur le forum de Cyrille BORNE, plus précisément le sujet traitant (comme par hasard) de la réparation des paquets sous LMDE, que j’ai trouvé comment afficher les paquets cassés : en faisant une simulation de mise à jour avec aptitude.
Lire la suite

Bientôt une install-party à Metz ? + autres liens sur le libre en Lorraine

Projet d’install-party à Metz

J’ai vu aujourd’hui sur le forum Ubuntu-fr qu’une install-party Ubuntu pourrait être organisée à Metz. Boolet (la personne à l’origine du projet) cherche pour cela des locaux et une date. Cette info est aussi présente sur le twitter de LibreEnLorraine qui recense les évènements liés au Libre dans la région.

Liste des GUL lorrains

Voici la liste des GUL (groupes d’utilisateurs Linux) en Lorraine d’après Lea-Linux et Wikipédia (j’ai enlevé les GUL dont le lien vers le site est mort) :

Bientôt un nouveau FAI lorrain ?

Vous connaissez le fournisseur d’accès FDN (French Data Network) ? Si non, il est présenté sur Wikipédia. Perso je l’ai découvert grâce à la fameuse vidéo de Benjamin Bayart Internet libre ou minitel 2.0 (sur fdn.fr, sur framablog). B. Bayart encourage l’essaimage de FDN dans les régions, pour rester un FAI associatif à taille humaine (je ne sais plus si c’est dans cette vidéo qu’il le dit ou une autre), et un tel projet voit actuellement le jour en Lorraine, nommé LDN pour Lorraine Data Network.

Avis aux amateurs pour un FAI alsacien

Par ailleurs, si vous êtes alsacien et intéressé par la création d’un FAI près de Strasbourg (à Eschau), je vous invite à lire ce sujet sur le forum ubuntu-fr.

Faille critique dans Firefox corrigée par une màj

Mise à jour : la faille est maintenant corrigée par Mozilla et fait l’objet d’une mise à jour.

Source : http://www.zdnet.fr/actualites/les-visiteurs-du-site-du-prix-nobel-attaques-via-une-faille-de-firefox-39755711.htm

Des chercheurs de l’entreprise de sécurité Norman ASA ont révélé mardi 26 octobre l’existence d’une faille de sécurité dans Firefox exploitée pour lancer une attaque contre les visiteurs du site officiel du Prix Nobel.

La vulnérabilité affecte les versions 3.5 et 3.6 du navigateur de Mozilla pour les plates-formes Windows. Elle permettait jusqu’à hier de déclencher des attaques de type drive-by download, c’est-à-dire « de faire télécharger et exécuter à l’insu de l’utilisateur un contenu » malveillant.

Pour se prémunir de cette faille en attendant un correctif, Mozilla recommande de soit :

  • désactiver le javascript dans Firefox (Édition, ou Outils, -> Préférences -> Contenu -> décocher « Activer JavaScript »)
  • installer l’extension NoScript qui permet de sélectionner les scripts autorisés

Oui le post est court, j’ai pas le temps de l’étoffer pour le moment, mais c’est assez important.

NoScript permet aussi de faire moins ramer le navigateur avec des tonnes de script (google adsense et autres pubs), il bloque aussi les éléments flash, et il m’a bloqué des XSS aussi. Bref même sous GNU/Linux je le trouve utile.

Joyeux anniversaire Toshi et bienvenue au suricate rebelle !

Aujourd’hui, 10/10/10, les geeks sont en furie car c’est 42 en binaire… Fautdrait peut-être que je lise le bouquin un jour, pour bien comprendre. Cependant, d’autres évènements marquent ce jour :
Lire la suite

Joli menu de déconnexion pour Openbox

Je vous avais parlé dans un billet précédent d’un beau menu de déconnexion pour Openbox, qui se trouve ici :
http://wiki.archlinux.fr/openbox-logout (celui proposé par joedu12). La capture d’écran d’exemple est celle-ci :

Lire la suite

Configuration du touchpad sous Archlinux

Avoir un environnement graphique, c’est bien, on peut lancer Firefox, et scroller avec la molette du touchpad… ou pas. Faut le configurer d’abord. Heureusement, il y a le wiki (francophone, anglophone) ! La page anglophone étant plus complète, je me suis basée sur elle. J’ai donc installé

xf86-input-synaptics

et

xf86-input-evdev

puis ai voulu installer GPointingDeviceSettings pour configurer le touchpad avec une belle interface graphique. Eh ben non : la compilation du package AUR échoue, comme dit dans les commentaires :

/usr/include/X11/extensions/XInput.h:1140:17: note: expected ‘struct Display *’ but argument is of type ‘int’
CCLD libgpds.la
CC gpointing_device_settings-gpointing-device-settings.o
CCLD gpointing-device-settings
./.libs/libgpds.so: undefined reference to `GDK_DISPLAY'
collect2: ld returned 1 exit status
make[2]: *** [gpointing-device-settings] Error 1
make[2]: Leaving directory `/tmp/yaourt-tmp-root/aur-gpointing-device-settings/src/gpointing-device-settings-1.5.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/yaourt-tmp-root/aur-gpointing-device-settings/src/gpointing-device-settings-1.5.1'
make: *** [all] Error 2

Finalement, je l’ai donc configuré dans le fichier /etc/X11/xorg.conf.d/10-synaptics.conf, comme décrit dans la partie « Frequently used options » :

Section "InputClass"
      Identifier "touchpad"
      Driver "synaptics"
      MatchIsTouchpad "on"
             Option "TapButton1" "1"
             Option "TapButton2" "2"
             Option "TapButton3" "3"
             Option "VertEdgeScroll" "on"
             Option "VertTwoFingerScroll" "on"
             Option "HorizEdgeScroll" "on"
             Option "HorizTwoFingerScroll" "on"
             Option "CircularScrolling" "on"
             Option "CircScrollTrigger" "2"
             Option "EmulateTwoFingerMinZ" "0"
EndSection

Et ça marche bien, j’ai le défilement horizontal, vertical, et l’émulation du bouton milieu, que du bonheur !🙂

Installation d’Archlinux

Ça fait quelques mois que j’ai installé Arch, et je viens de la personnaliser vraiment (je l’avais un peu laissée tomber), donc je vais publier poster quelques billets à ce sujet. C’est pas très compliqué, à condition de ne pas avoir peur de lire des wikis (wiki francophone) et forums (forum francophone), francophones et anglophones, et ne pas vouloir un truc tout prêt en 30 min. Le wiki francophone est super pour commencer la config je trouve, et les gens du forum sont sympas.

Lire la suite

Activer le mode UserDir et le php sous Apache

J’ai installé Apache2 en local, et ai voulu tester une page php dans mon dossier public_html. Pour cela j’ai donc activé le module UserDir à l’aide de la commande

sudo a2enmod userdir

Cependant, au lieu d’avoir ma page php qui s’affichait, j’avais une boite de dialogue de Firefox me disant :

Vous avez choisi d’ouvrir le fichier … qui est un fichier PHTML. Que doit faire Firefox avec ce fichier ?

ou quelque chose comme ça. (Oui j’ai oublié la capture d’écran)

J’ai cherché un moment, et j’ai fini par tomber sur la solution sur ce site :
http://cobex4.dhrclic.com/apache2-activer-le-public_html-sur-ubuntu-10-4/
qui indique que le php n’est tout simplement pas activé par défaut pour les dossiers public_html. Il faut donc commenter les lignes le désactivant dans le fichier /etc/apache2/mods-available/php5.conf comme indiqué sur le site source :

#    <IfModule mod_userdir.c>
#        <Directory /home/*/public_html>
#            php_admin_value engine Off
#        </Directory>
#    </IfModule>

Si le fichier php5.conf n’est pas présent (cas de mon installation d’Apache sur LMDE – Linux Mint Debian Edition), il faut simplement installer php5.

On peut ensuite redémarrer Apache et voir nos pages php !

Suivre

Recevez les nouvelles publications par mail.